WordPress被黑客入侵应该怎么办?

  • A+

帮帮我!我的WordPress已被黑客入侵!

它几乎可以发生在任何WordPress网站上。有时黑客来自旧版本的WordPress,插件或主题。当在WordPress中发现新的漏洞时也会发生这种情况,但可能尚未发布可用于更新此漏洞的更新。

你能做什么?

首先,您需要删除所有黑客行为,您可以与我们联系以协助扫描您的帐户,或者查看下面扫描您帐户的一些步骤。接下来,您需要采取一些措施来防止这种情况再次发生。以下是一些有助于保护您的网站的步骤:

更新WordPress,插件和主题

因为黑客经常来自旧版本的WordPress,插件或主题,所以更新所有插件,主题或WordPress版本以确保黑客不会利用相同的漏洞非常重要。如果主题或插件已过时,且开发人员不再支持更新,则可能需要考虑查找仍在积极支持和更新的新主题或插件。

WordPress被黑客入侵应该怎么办?

Wordfence

您可能需要考虑获得一个WordPress安全插件,以阻止强力登录或扫描漏洞。Wordfence Security是一款免费的安全插件,可以扫描WordPress网站的漏洞和已知威胁。您可以在此链接查看该插件:

http://wordpress.org/extend/plugins/wordfence/

注意: Wordfence使用略高的  PHP  内存运行。如果您想安装它,您需要将php.ini文件中的内存限制更改为56M。如果您不确定如何操作,请联系我们。

病毒扫描

如果您就这种黑客行为与我们联系,那么我们会自动扫描此帐户以删除任何注射。但是,如果您想自行扫描您的站点以阻止PHP Shell脚本,则可以在您的帐户上运行自己的病毒扫描。许多最新的防病毒程序可以检测  PHP  Shell脚本。AVG就是一个很好的例子。
要将其作为资源使用,请按照以下步骤操作:

  • 通过FTP登录您的帐户  。
  • 将他们所有的WordPress文件下载到本地机器上。(包括wp-admin,wp-content和wp-includes文件夹中的所有文件和文件夹。)
  • 用您的防病毒程序扫描文件和文件夹。

扫描完成后,您的防病毒程序应通知您。它应该为您提供哪些文件包含PHP  Shell脚本的日志  。

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: